lkml.org 
[lkml]   [2003]   [Mar]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: Oops in firewire (2.4.21-pre5 with 2.4.21-pre4 firewire driver)
From
Date
On Wed, 2003-03-12 at 22:11, Ben Collins wrote:
> On Wed, Mar 12, 2003 at 05:06:23PM -0800, Torrey Hoffman wrote:
[ohci1394 / sbp2 problems]

> I'd suggest with trying the latest BK cset patch (which fixes -pre5 and
> also fixes some things in general).

Thanks for the response.

Last night I (finally) installed bitkeeper, pulled the latest 2.4 tree,
and gave it a try. It seems to have solved the problem on my single CPU
machine. I will try my SMP machine tonight and see how things go there.

I run reiserfs on my firewire drives but ext3 on some other partitions.
These oops have often occurred when doing rsync's between the reiserfs
on firewire and an ext3 or reiserfs partition on a regular disk or raid5
setup.

On my SMP machine this morning (using Red Hat's 2.4.18-18smp kernel) I
had a similar oops with references to kjournald under a heavy firewire
load. The machine didn't die, and after the bus resets completed, the
rsync from the firewire drive continued.

These oopses have been very reproducible while loading ohci1394, and
sometimes while transferring data after loading. They don't occur if
the sbp2 device is not attached. I have hacked my rc.sysinit script to
always load the drivers, since Red Hat's autodetection stuff there quit
working around 2.4.18-17, and as long as the device isn't attached
2.4.18-24 boots fine and loads the drivers.

Up until installing 2.4-bk last night, I normally booted to Red Hat's
2.4.18-24 kernel, except when I need to use firewire. 2.4.18-24 doesn't
work at all for me under firewire, and 2.4.18-18 "mostly" works.)

Anyway, I will upgrade all my machines to the latest -bk snapshot and
will be back with more bug reports if I see any glitches...

Hopefully Red Hat will update their official kernel with the firewire
fixes. And fix their rc.sysinit script too, while they are at it. (No,
I haven't submitted a bugzilla report yet, will do so if -bk fixes
things for me...)

Thanks again,

Torrey Hoffman


>
> > I got an oops while loading the driver. I will continue to experiment
> > with recent kernels, and try to find a bitkeeper snapshot with the
> > latest firewire fixes. Any suggestions are welcome.
>
> > >>EIP; c016e639 <__journal_remove_checkpoint+39/90> <=====
>
> This happened in the kjournald thread context. I'm not sure it is
> ieee1394 related, but it is suspect that it happened in the middle of
> handling an ieee1394 bus reset.
>
> Is this reproducible when loading the ohci1394 driver? If so, does it
> occur when you turn off hotplug (IOW, don't load sbp2 driver) or if the
> sbp2 device is not attached?
>
> --
> Debian - http://www.debian.org/
> Linux 1394 - http://www.linux1394.org/
> Subversion - http://subversion.tigris.org/
> Deqo - http://www.deqo.com/
>


-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:33    [W:0.038 / U:1.408 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site