lkml.org 
[lkml]   [2003]   [Mar]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: Oops: kernel 2.4.20, ide-scsi, cdrecord 1.11a24
Date
Hi all

This is a followup to my previous message regarding a consistant
reproducable oops under 2.4.20 when burning CDs using cdrecord and ide-scsi.

Last night I tried disabling DMA on the CD drive (it was enabled by
default):
hdparm -d0 -c1 /dev/hdc

Following this, two dummy writes (700MB and 680MB respectively) proceeded
normally and completed without errors. Given that under 2.4.20 the dummy
writes usually failed very quickly (after around 7-30MB), it would appear
that in the first instance at least, DMA must be disabled for ide-scsi CD
writers under 2.4.20 in order for burning to be reliable.

Obviously this isn't the intended behaviour though; is anyone aware of this
issue and/or is it being worked on for 2.4/2.5 as appropriate?

Best regards
jonathan
--
* Jonathan Woithe jwoithe@physics.adelaide.edu.au *
* http://www.physics.adelaide.edu.au/~jwoithe *
***-----------------------------------------------------------------------***
** "Time is an illusion; lunchtime doubly so" **
* "...you wouldn't recognize a subtle plan if it painted itself purple and *
* danced naked on a harpsichord singing 'subtle plans are here again'" *
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:33    [W:0.026 / U:2.080 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site