lkml.org 
[lkml]   [2003]   [Mar]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: IOAPIC on Via KT266a
On Fri, Feb 28, 2003 at 03:19:01PM +0100, Mikael Pettersson wrote:

> This is almost certainly a hardware problem: your machine's APIC bus
> is corrupting messages, or some other agent than the CPU is creating
> corrupt messages. This isn't exactly unheard of for non-Intel chipsets.

Hmmm... windows seems to have a workaround for at least part of the
problem, I spent the last day trying to confuse the APIC unsuccessfully
on that system. Could it be a problem with the uhci driver perhaps?
The only two persistant symptoms are the usb failure and the slew of
messages.

The APIC errors I receive are mostly 02(02) but a good deal of
02(01), 01(02) and 01(01). Checksum errors galore.

This only happens with IO-APIC is enabled throughout:

hub.c: new USB device 00:11.2-1, assigned address 2
usb_control/bulk_msg: timeout
usb.c: USB device not accepting new address=2 (error=-110)
hub.c: new USB device 00:11.2-1, assigned address 3
b.c: USB device not accepting new address=3 (error=-110)
hub.c: new USB device 00:11.2-2, assigned address 4
usb_control/bulk_msg: timeout
usb.c: USB device not accepting new address=4 (error=-110)
hub.c: new USB device 00:11.2-2, assigned address 5
usb_control/bulk_msg: timeout
usb.c: USB device not accepting new address=5 (error=-110)

--
Josh Litherland (fauxpas@temp123.org)
[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2005-03-22 13:33    [W:0.060 / U:5.088 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site