lkml.org 
[lkml]   [2003]   [Feb]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectCyrix III processor and kernel boot problem
Hello,
I made an unsuccessfull search on the m-l archive about this problem, so
now I'm going to report it in the developing m-l.
I own a Cyrix III processor (400 Mhz up to 800Mhz) on a via chipset
motherboard. When I boot with a kernel compiled for Cyrix processor or
with a 686 pentium the lilo gets the images, put it on memory and
decompress it, but when it has to boot (after the "Loading
mlinuz..........") it always reboot the computer.
I've found out that the Cyrix III has no CMOV instruction and that this
could be the problem.
So I compiled a pentium mmx version (after mrproper and dep) and all
worked fine.
My question is: ok, it can't work if 686 compiled, but why does not it
work also for the Cyrix III version?

I tried a "vanilla" kernel and some htb pathced one.
kernel versions: 2.4.19 and 2.4.20.
hope my report will help

keep up the good work

feel free to contact me

bye

c1cc10
--
pub 1024D/76A9AC52 2002-12-13 ciunociciunozero (PORCODIO) <c1cc10@ecn.org>
Key fingerprint = 64A9 9498 B297 B49F D676 AAA1 9DA9 CABA 76A9 AC52
sub 2048g/F248FA79 2002-12-13 [expires: 2004-12-12]


-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:33    [W:0.059 / U:3.552 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site