lkml.org 
[lkml]   [2003]   [Feb]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectParam-oldstyle.patch
Date
From
Dear all,

I receive the following error message while compiling an 'old-style'
driver in 2.5.59:
'MOD_IN_USE': undeclared function

However, when applying 'param-oldstyle.patch.gz' to support old-style
"MODULE_PARM" declarations, I get

Patching file include/linux/module.h
Reversed (or previously applied) patch detected! Assume -R? [n]

I think that if the patch had already been applied, I should get an
option:
[]config OBSOLETE_MODPARM

But my current kernel configuration looks like this and I can't find
[]config OBSOLETE_MODPARM anywhere:

[Y]Enable loadable module support
[Y] Module unloading
[]Forced module unloading
[Y] Kernel module loader

I would be grateful for any advice on how to successfully apply the
patch and compile this device driver for 2.5.59.

Thank you.

Regards,
Se-Hsieng


-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:33    [W:0.024 / U:6.424 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site