lkml.org 
[lkml]   [2003]   [Feb]   [24]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: Box freezes if I enable "AMD 76x native power management"
From
Date
Just another voice in the crowd...

TYAN 2462 dual 1200MP, and another w/ dual 1900MP
Dual WD100 IDE, seperate channels
Current BIOS 2.13
1GB RAM

I noticed this behavior when I started playing with 2.4.20 and could
never figger it out - went so far as to bring up KGDB and was way down
in the IDE DMA code, scary stuff... Kept scanning LKML and finally found
this gem of a thread...

Ran up a clean, fresh kernel from pre4-ac5, four combos
1) CONFIG_AMD_PM768=Y CONFIG_BLK_DEV_IDEDMA_PCI=y
2) CONFIG_AMD_PM768=m CONFIG_BLK_DEV_IDEDMA_PCI=y
3) CONFIG_AMD_PM768=Y CONFIG_BLK_DEV_IDEDMA_PCI is not set
4) CONFIG_AMD_PM768=m CONFIG_BLK_DEV_IDEDMA_PCI is not set

In cases 1 and 3, hang at boot, pressing the power button frees it up.
In cases 2 and 4, no boot hang, and, at lease for me, no hang when
amd76x_pm module's loaded

So, back to playing - if you need some testing on this board, let me
know - I use one at work and one at home, takes no time at all to gen up
and try things out, and they'll get pretty good exercise.

Regards,
Gio

Please cc: - not subscribed to LKML

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:33    [W:0.019 / U:3.080 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site