lkml.org 
[lkml]   [2003]   [Feb]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subject2.4.20-ac1 not seeing IDE disk on PIIX host adapter
Hi,

I have here a recent Acer notebook which I plan to use with Linux. The
system I installed uses Kernel 2.4.20-ac1 which is the kernel we use
on most other production systems at our site. The notebook has an 810
chipset; the IDE chip is seen by the normal PIIX driver.

Linux 2.4.20-ac1 sees the PIIX chip, but not the disks connected to
it. This of course results in a kernel panic "unable to mount root
fs". Same thing happens with 2.4.20-ac2. Vanilla 2.4.20 works fine. Of
course, all kernels have been built with the same configuration.

2.4.20 is fine for this notebook, so this issue has no urgency for me
in any way. I just wanted to point out potential problems to the
people capable of investigating. I'll happily provide any information
that might be required.

Cheers
Marc

--
-----------------------------------------------------------------------------
Marc Haber | "I don't trust Computers. They | Mailadresse im Header
Karlsruhe, Germany | lose things." Winona Ryder | Fon: *49 721 966 32 15
Nordisch by Nature | How to make an American Quilt | Fax: *49 721 966 31 29
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:33    [W:0.087 / U:7.120 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site