lkml.org 
[lkml]   [2003]   [Feb]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: 2.4 series IDE troubles
On 21 Feb 2003 18:59:40 +0000, Alan Cox wrote:
> With 2.4.21pre (the firs 2.4 IDE I hacked on seriously) pcmcia flash
> works on my test setups, and gets used fairly hard for digital cameras

Anyone tried booting a recent Toshiba Laptop from PCMCIA?
I have, and it doesn't work. Not that this necessarily has anything to do
with the IDE code. I have tried both recent -ac and vanilla.

In short, if I load the kernel from PCMCIA, the CardBus slots disappear
from the PCI bus. -> no root device -> boom!

If I load the kernel from any other medium (haven't tried PCMCIA netboot),
the CardBus slots are present.

Is this a Toshiba oddity for which there isn't a PCI quirk yet?
Any suggestions for debugging?

Dag B.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:33    [W:0.047 / U:1.524 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site