lkml.org 
[lkml]   [2003]   [Feb]   [20]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subjectvcdxrip , CDROM_SEND_PACKET, and 2.5.42->2.5.43 ide-cd changes


Hi,

I often use vcdxrip to pull mpeg data off of
old vcd's/svcds to archive to tape/dvd. This
worked fine in the 2.5 kernel series up to
2.5.42 where it worked after running the app
more then once ( i assumed it was an initialization
error someplace). After kernel 2.5.43 it no longer
works. I've sent mail to the authors and they
suggested switching it from using ioctl(CDROM_SEND_PACKET)
to ioctl(CDROMREADMODE2) , which does work only
a little slower.

I've traced it down to cdrom_queue_packet_command() in ide-cd.c
returning a 0 error status from ide_do_drive_cmd(), and
req.data_len is 0, and there doesn't appear to be any sense
available.


I'd appreciate any suggestions for tracking this further
or ideas on possible causes.

-pee


-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:33    [W:0.037 / U:4.368 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site