lkml.org 
[lkml]   [2003]   [Feb]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [Bug 379] New: VIA 8235 rear channel playback on front channels?
At Tue, 18 Feb 2003 23:00:00 -0800,
Martin J. Bligh <mbligh@aracnet.com> wrote:
>
> http://bugme.osdl.org/show_bug.cgi?id=379
>
> Summary: VIA 8235 rear channel playback on front channels?
> Kernel Version: 2.5.62
> Status: NEW
> Severity: normal
> Owner: bugme-janitors@lists.osdl.org
> Submitter: ricko73@yahoo.com
>
>
> Distribution: Slackware 8.1
> Hardware Environment: EPIA-M 9000
> Software Environment: VIA 8235 ALSA kernel drivers
> Problem Description: During DVD playback on Mplayer, (using ALSA sound), sound
> only comes out of the main two channels (front left and right), but that sound
> is supposed to be in the REAR two channels.

which ac97 codec is on this board? if it's an ALC650, check whether
the downmix switch is not set.

also, please check which chip is in fact from /proc/asound/cards.
the behvior of the driver depends on the chip model.

if it's really a VIA8235, i guess mplayer accessing to the first pcm
device, which supports only the front playback. the multi-channel
playback is supported on the second pcm.


--
Takashi Iwai <tiwai@suse.de> SuSE Linux AG - www.suse.de
ALSA Developer ALSA Project - www.alsa-project.org
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:33    [W:0.034 / U:0.156 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site