lkml.org 
[lkml]   [2003]   [Feb]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
SubjectRe: yenta-cardbus IRQ0
From

<quote who="Robert Bisping">
> On Friday 31 January 2003 08:50, you wrote:
>> <quote who="Robert Bisping">
>>
>> > i have been trying to set up a cardbus card on my thinkpad 760ED for about the
>> last month and it keeps coming up with IRQ0 and telling me it cant find a irq for
>> pin A. what would be causing this and how do I correct it i have already tried
>> APCI and it does not work on my laptop so that is no help. I have compiled SMP
>> into the kernel though I dont have a dual processor (of course) to gain the added
>> functionality. I have recompiled my kernel about 150 times with different setting
>> hoping it might just be a conflict in the kernel with no luck. I looked at the
>> yenta driver it's self and noticed that it accepts IRQ0 as a valid irq but that
>> appears to mean no irq at all. which config file would i use to force it to set a
>> irq?
>> >
>> >
>> > Thanx for any assistanc you might give
>>
>> plz send an lspci -vv -xxx -s *your dev*
>>
>> what kernel are you using ?
>
> i am using 2.4.18 and here is lspci


uhmm, 1th try to upgrade to a newer one, then I experienced the same problem with a
custom board... the problem was triggered by the Base Address too high:

Region 0: Memory at 10812000 (32-bit, non-prefetchable) [size=4K]

moving id_sel (in the PCI core of the board) in order to obtain a lower bar all worked.


BTW, has anybody there ever heared about such a costraint in the PCI specification ??
Why I got this strange behaviour ???

--
Emiliano Gabrielli

dip. di Fisica
2° Università di Roma "Tor Vergata"


-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:32    [W:0.050 / U:0.148 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site