lkml.org 
[lkml]   [2003]   [Feb]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: NFS problems, 2.5.5x
The last time NFS was working, I had 2.4.19 and 2.5.53 clients on a 
2.5.59 server, that was yesterday. I had experienced a slight problem
with it last week when my 2.5.53 client was booted for first time on
2.5.5x, it was previously a 2.4 kernel. The server OOPSed repeatedly
shortly after bootup in NFS stuff then it never happened again and was
rock solid until today.

David

Trond Myklebust wrote:

>>>>>>" " == David Ford <david+powerix@blue-labs.org> writes:
>>>>>>
>>>>>>
>
> > Synopsis: nfsserver:/home/david mount, get dir. entries loops
> > forever,
> > 2.5.59 for client and server.
>
> > Example: ls -l /home/david
>
> > An strace will show the same directory entries flying by over
> > and over until memory is exhausted or ^c comes along. It
> > worked at first for about 30 minutes while I finished the new
> > gentoo install on my desktop, but then things got weird. the
> > nfs server spat out a big long callback trace (oops) and died
> > hard. Had to reset the power. The looping started just
> > minutes before that. I've rebooted, tried 2.5.53 on the client
> > but no go.
>
>AFAICR, there have been no changes to the NFS client readdir code since
>2.5.30.
>
>Cheers,
> Trond
>
>

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:32    [W:0.054 / U:4.744 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site