lkml.org 
[lkml]   [2003]   [Feb]   [1]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: 2.4.20 kernel crashes while scanning partition list
Doug McNaught:

> Have you tried 2.4.21pre? It may have fixes to handle newer hardware.

I tried the 2.4.21pre4, and it crashes as well, seemingly in the exact
same spot as the other kernels. I also tried 2.5.59, but I couldn't get
it to find the array at all (it does list the IDE channels, though).

Here's a summary of what happens:

Kernel Finds IDE? Finds array? Finds partitions
------ ---------- ------------ ----------------
2.4.18 No Yes* Yes, and boots fine
2.4.19 Yes Yes Crashes when enumerating
2.4.20 Yes Yes Crashes when enumerating
2.4.21pre4** Yes No No partitions found
2.4.21pre4*** Yes Yes Crashes when enumerating
2.5.59 Yes No No partitions found

* When fed IDE channels on the command line
** With configuration copied from 2.4.20.
*** Enabled the non-ataraid options for Promise FastTrak.

The configuration for 2.4.19--21 should be the same. 2.4.18 is
pre-built version from Debian's boot-floppies. Source for 2.4.21pre4
and 2.5.59 are pristine kernel.org sources. (My 2.5.59 configuration
might have been flawed, however.)

As before, all relevant debugging material may be found at
<URL:http://www.softwolves.pp.se/tmp/2.4.20>


I could really need some help debugging. I can set up an account on my
machine (I have a cable tv connection), and set up a null modem cable
from the problematic machine if that would be helpful. I don't really
know much about kernel debugging, especially when it crashes before the
system has actually started up.

--
\\//
Peter

I do not read or respond to mail with HTML attachments.


-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:32    [W:0.078 / U:4.680 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site