lkml.org 
[lkml]   [2003]   [Dec]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    Date
    From
    SubjectRe: 2.4.23aa1 - scsi/pcmcia qlogic still does not build (m)
    Andrea Arcangeli wrote:
    > Also for the i2c troubles (you mentioned those last time), you can try
    > if this helps.

    I applied fixes similar to your suggestion to i2c-2.7.0
    and lm_sensors-2.7.0 to get these to build, looks OK.

    My final depmod has this problem though:

    depmod: *** Unresolved symbols in
    /lib/modules/2.4.23aa1/kernel/drivers/video/sis/sisfb.o
    depmod: __floatsidf
    depmod: __divdf3
    depmod: __fixunsdfsi
    depmod: __muldf3
    depmod: __adddf3

    I do not have this problem with 2.4.23, and I see the -aa1 patch
    actually removing some FP ops. But therer are some left in other
    sources (e.g. sis_main.c) so maybe some link problem was exposed?

    Reverting the sis/init.c hunk does not fix this. Can it be related
    to this in arch/i386/Makefile:

    -CFLAGS += -pipe
    +CFLAGS += -pipe -msoft-float

    --
    Eyal Lebedinsky (eyal@eyal.emu.id.au) <http://samba.org/eyal/>
    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2005-03-22 13:59    [W:0.021 / U:0.104 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site