[lkml]   [2003]   [Dec]   [29]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectCan't mount USB partition as root

    I tried to boot Linux 2.6.0 kernel with option root=/dev/sda1 using Grub.
    The kernel otherwise works, mounts the sda1 partition (XFS) OK.
    When I boot the kernel with root=/dev/sda1 instead of root=/dev/hda4,
    I get "can't mount root VFS, kernel panic" or something like that.

    Is it possible to boot kernel with root from /dev/sda1 (USB)?
    partition table: whole /dev/sda is one partition (sda1), type 83 (Linux).
    Tried also switching on and off hotplugging in kernel and it didn't help.

    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    More majordomo info at
    Please read the FAQ at

     \ /
      Last update: 2005-03-22 13:59    [W:0.019 / U:50.224 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site