lkml.org 
[lkml]   [2003]   [Dec]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: Radeon 7500 DRI Failed on IBM Thinkpad T30
From
Date
On Tue, 2003-12-02 at 07:10, arief_mulya wrote: 
> I'm having DRI problem on my IBM Thinkpad T30 with Radeon 7500.
> Sometimes it works, oftenly it doesnt. Withoud "Load dri" in
> XF86Config-4, it work just fine.
>
> For first information, I got this problem too under WindowsXP, even
> worse, it hangs after few seconds I login, sometimes, it doesn't let me
> login at all and just printing some messages on BSOD so fast, I cannot
> even see what it was actually printing. I just disabled the VideoCard
> and uses Vesa instead. I rarely need to do winboot afterall.

[...]

> I'm curious if this is an hardware bug?

It does smell like it, if Windoze is affected as well...

Still, I can think of a couple of things you could try:

* disable the __HAVE_SHARED_IRQ definition in
linux/drivers/char/drm/radeon.h; seems to work around some IRQ
related problems, see
http://bugs.xfree86.org/show_bug.cgi?id=314
* try DRI CVS snapshot packages described in
http://dri.sourceforge.net/snapshots/README.Debian


--
Earthling Michel Dänzer | Debian (powerpc), X and DRI developer
Software libre enthusiast | http://svcs.affero.net/rm.php?r=daenzer
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:59    [W:0.021 / U:6.524 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site