lkml.org 
[lkml]   [2003]   [Dec]   [2]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
Date
From
Subject[PATCH] IDE modules + cmd640 (2.4.22)
Hi again.

This should fix IDE module dependency problems with CMD640 support.

I have sent this same patch before (on September 22nd) for kernel
2.4.22, to the same recipients. While it bounced for one recipient
('andre@linux-ide.org'), it reached the mailing list, but I never got
any answers.

Anyway, as I'm right back in the middle of kernel compilation (do_brk,
*sigh*), I've just noticed that the IDE modules and CMD640 problem
/still/ persists. So please read on (reading '2.4.22' as '2.4.23'):

-----------------------------------------------------------------------

This patch intends to fix an unresolved symbol 'init_cmd640_vlb' error
when compiling kernel 2.4.22 using

CONFIG_IDE=m
CONFIG_BLK_DEV_IDE=m

and an enabled 'CONFIG_BLK_DEV_CMD640' option. The problem would show up
on the first attempt to run 'depmod' or otherwise deal with IDE modules.

I've not seen any fix for this in any recent prerelease.

The problem is caused by the way 'cmd640' is made part of the kernel. If

CONFIG_BLK_DEV_CMD640=y

(which is the only answer offered besides 'n' for a stock 2.4.22), the
'cmd640' code will be put into the kernel statically. As 'ide-core.o'
will be a module and it will contain a reference to the (unexported)
function 'init_cmd640_vlb' of 'cmd640.c', symbol resolution will fail.

The following patch assumes that 'cmd640' is meant to be an independent
module now (as all other IDE drivers in 'drivers/ide/pci') if IDE core is
modular. The patch only adds the required configuration option changes to
allow an additional answer 'm' for 'CONFIG_BLK_DEV_CMD640' (and disabling
'y' completely if IDE is modular). Boolean 'CONFIG_BLK_DEV_CMD640_ENHANCED'
may now be set to 'y' if 'CONFIG_BLK_DEV_CMD640' is either 'y' or 'm'.

With

CONFIG_BLK_DEV_CMD640=m'

the reference to 'init_cmd640_vlb' from 'ide.c' will be omitted, leaving
VLB handling to the respective module parameter of 'cmd640.o', so there's
no longer any unresolved symbol.

NB: While I have verified that symbols resolve cleanly and 'cmd640.o' loads
without problems, I currently have no hardware to actually test any
CMD640 chipsets on (I only added the driver to my configuration for
completeness), so I cannot tell whether the modular driver actually
works as it should. At least it doesn't break IDE module loading now.

Best regards,
Alex

[ Please send answers to my From address.
I'm not subscribed to the kernel mailing list. ]
diff -ur linux-2.4.22/drivers/ide/Config.in linux-2.4.22-cmd640fix/drivers/ide/Config.in
--- linux-2.4.22/drivers/ide/Config.in Mon Aug 25 13:44:41 2003
+++ linux-2.4.22-cmd640fix/drivers/ide/Config.in Sun Sep 21 17:03:19 2003
@@ -27,8 +27,8 @@

comment 'IDE chipset support/bugfixes'
if [ "$CONFIG_BLK_DEV_IDE" != "n" ]; then
- dep_bool ' CMD640 chipset bugfix/support' CONFIG_BLK_DEV_CMD640 $CONFIG_X86
- dep_bool ' CMD640 enhanced support' CONFIG_BLK_DEV_CMD640_ENHANCED $CONFIG_BLK_DEV_CMD640
+ dep_tristate ' CMD640 chipset bugfix/support' CONFIG_BLK_DEV_CMD640 $CONFIG_X86 $CONFIG_BLK_DEV_IDE
+ dep_mbool ' CMD640 enhanced support' CONFIG_BLK_DEV_CMD640_ENHANCED $CONFIG_BLK_DEV_CMD640
dep_bool ' ISA-PNP EIDE support' CONFIG_BLK_DEV_ISAPNP $CONFIG_ISAPNP
if [ "$CONFIG_PCI" = "y" ]; then
bool ' PCI IDE chipset support' CONFIG_BLK_DEV_IDEPCI
\
 
 \ /
  Last update: 2005-03-22 13:59    [W:0.024 / U:0.036 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site