lkml.org 
[lkml]   [2003]   [Dec]   [19]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    From
    SubjectRe: 2.6-test11 framebuffer Matrox
    Date
    In article <200312190314.13138.schwientek@web.de>, Steffen Schwientek wrote:
    > My Matrox-framebuffer is not working properly. Build direct into the
    > kernel, the monitor will be black with some stripes at startup, just the
    > reset button works.
    > Build as a modules, the same happens if I load the module.

    I've managed to get my AGP G400 working in the following setups under
    2.6.0 since -test7:

    with Petr's patch, reverting to 2.4 interfaces:
    video=matroxfb:vesa:0x1bb gives me a great fbcon. I can either use
    X's fbdev driver at the same resolution, or the mga driver at any
    resolution, with no problems.

    without Petr's patch:
    video=matroxfb:vesa:0x1bb gives me a great fbcon. I can only use
    X's fbdev driver at the same resolution; the mga driver at any
    resolution causes massive console corruption upon switching from X to
    console and causing any screen changes. Also, I get a large white
    block underneath the logo on boot.

    --
    nick black <dank@reflexsecurity.com>
    "np: nondeterministic polynomial-time
    the class of dashed hopes and idle dreams." - the complexity zoo

    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2005-03-22 13:59    [W:0.020 / U:208.296 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site