[lkml]   [2003]   [Nov]   [8]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
    SubjectRe: Re:No backlight control on PowerBook G4
    On Fri, 2003-11-07 at 20:50, Daniel Egger wrote:
    > Am Don, den 06.11.2003 schrieb Benjamin Herrenschmidt um 01:28:
    > > No, I told you to use _my_ 2.6 tree which contains a new radeonfb
    > > that have not yet been merged upstream.
    > Still cannot try this because your kernel wouldn't even survive yaboot.

    Can you give details ? It should work just fine, except if I broke
    something in the past few days when getting G5 support in, but I didn't
    have any other report of this, so...

    > With your tree I now have the problem that it doesn't even boot anymore.
    > The CHRP kernel which worked before stopped after "CHRP kernel
    > loader...", the elf-pmac one still crashes with:
    > Elf32 kernel loaded...
    > chrpboot starting: loaded at 0x01000000
    > heap at 0x00003000
    > gunzipping (0x00010000 <- 0x01006cf8:0x01155486)...
    > Decrementer exception at %SRR0: 01005804 %SRR1: 00003030
    > ok
    > 0 >

    Well, you are not supposed to use the zImage.chrp on a PowerMac,
    and definitely not from yaboot.

    It may have altered some open firmware settings in a bad way.
    I suggest you reset your nvram first (hopefully, booting with
    cmd-opt-P-R will do the trick).

    Last I tried, then just netbooting vmlinux.elf-pmac worked fine
    on all the "newworld" models I have here). For yaboot, you need
    to load a plain vmlinux binary.


    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to
    More majordomo info at
    Please read the FAQ at

     \ /
      Last update: 2005-03-22 13:58    [W:0.020 / U:48.872 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site