lkml.org 
[lkml]   [2003]   [Nov]   [6]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: load 2.4.x binary only module on 2.6
From
Date
On Thu, 06 Nov 2003 14:33:12 EST, Gene Heskett said:

> I've got minions 4496 here, so how did you make it work? I had to
> revert to the kernel driver nv which doesn't do as much, but is
> easily 100000% more stable.

Got NVidia's tarball, did the --extract-only thing, applied
the Minion patch, 'cp Makefile.kbuild Makefile', reboot to the
-mm2 kernel, 'cd src/NVdia<mumble>/usr/src/nv && make'.

Actually, I've just had to do the 'make' for the last umpteen kernel
revs - the Makefile dates back to Aug 4, and Sep 5 I had to apply a
2-line fix to nv-linux.h.

Not sure if the nv driver could be more stable - the last time I was
able to tickle the NVidia code into crashing either XFree86 or the kernel
was back in the 2.5.6* time frame.
[unhandled content-type:application/pgp-signature]
\
 
 \ /
  Last update: 2005-03-22 13:58    [from the cache]
©2003-2011 Jasper Spaans