lkml.org 
[lkml]   [2003]   [Nov]   [26]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: amanda vs 2.6
Date
On Wednesday 26 November 2003 15:04, Linus Torvalds wrote:
>On Wed, 26 Nov 2003, William Lee Irwin III wrote:
>> On Wed, Nov 26, 2003 at 02:43:43PM -0500, Gene Heskett wrote:
>> > No, it just hangs forever on the su command, never coming back.
>> > everything else I tried, which wasn't much, seemed to keep on
>> > working as I sent that message with that hung su process in
>> > another shell on another window. I'm an idiot, normally running
>> > as root... I've rebooted, not knowing if an echo 0 to that
>> > variable would fix it or not, I see after the reboot the default
>> > value is 0 now.
>>
>> Okay, then we need to figure out what the hung process was doing.
>> Can you find its pid and check /proc/$PID/wchan?
>
>I've seen this before, and I'll bet you 5c (yeah, I'm cheap) that
> it's trying to log to syslogd.
>
>And syslogd is stopped for some reason - either a bug, a mistaken
> SIGSTOP, or simply because the console has been stopped with a
> simple ^S.
>
>That won't stop "su" working immediately - programs can still log to
>syslogd until the logging socket buffer fills up. Which can be
> _damn_ frsutrating to find (I haven't seen this behaviour lately,
> but I remember being perplexed like hell a long time ago).
>
> Linus

Ok, then, this is not what I'm seeing. The last su amanda was done on
an almost virgin shell, having only executed that echo 1 to the
overcommit_memory var in /proc.

I tried it from other shells too, no difference, su is locked, cannot
even respond to a ctrl-c or ctrl-d. But the close button will close
the shell window just fine.

Also, echoing a 0 to that variable doesn't fix it.only a reboot fixes
it. Right now:
[root@coyote root]# ps -ea |grep syslogd
406 ? 00:00:00 syslogd
[root@coyote root]# echo 1 > /proc/sys/vm/overcommit_memory

which didn't kill syslogd:
[root@coyote root]# ps -ea |grep syslogd
406 ? 00:00:00 syslogd

Ok, I'll play this game, as long as I know the rules, I have now done
an "su amanda" in two different shells, without any problems, and a
"cat /proc/sys/vm/overcommit_memory" returns this:
[amanda@coyote root]$ cat /proc/sys/vm/overcommit_memory
1
[amanda@coyote root]$

The two previous boots to the same kernel, 2.6.0-test10 using the
default scheduler, hung the su command and failed at exactly this
same point.

I think I need a new rulebook...



--
Cheers, Gene
AMD K6-III@500mhz 320M
Athlon1600XP@1400mhz 512M
99.27% setiathome rank, not too shabby for a WV hillbilly
Yahoo.com attornies please note, additions to this message
by Gene Heskett are:
Copyright 2003 by Maurice Eugene Heskett, all rights reserved.

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:58    [W:0.063 / U:3.320 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site