lkml.org 
[lkml]   [2003]   [Nov]   [15]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
    /
    From
    SubjectRe: 2.6.0-test9 VFAT problem
    Date
    > I'd like to put this thread on hold
    > until I take stock of the steps I've taken just to make sure I've not been a
    > right 'plum'.

    Hi,
    Right, I'm not sure if I've been a 'plum' or not. In fact I'm not sure
    about anything now.
    Friday when I got home I tried to mount my belkin reader with sda in the
    fstab. I got 'no media found'. I then tried to mount my Olympus camera and
    got 'wrong fs...'. I changed my fstab to sda1 and tried again. This gave
    the same two errors. I rebooted the pc and this time I could mount the
    camera, but the belkin usb reader still gave 'no media found'. I then put
    the original inode.c back into my source and recompiled. And to my
    complete surprise the camera mounted. The belkin however gave 'no media
    found'.
    All the above would suggest I've been a 'plum' - however I've done this
    before with 2.4. I do tend to be able to get things working by reading
    and not bothering good people like yourselves.

    Now I have done some further tests and I have found something strange. I
    can mount my camera with a 64mb and 16mb smart media. The belkin reader,
    if I put the 64mb card in, I get 'no media found'. If I then put the 16mb
    card in I also get 'no media found'. If I disconnect and reconnect the
    belkin I can mount the 16mb card. If I then put the 64mb in I get 'no
    media found'. Putting the 16mb back in gives 'no media found'.
    disconnecting and reconnecting the reader allows me to mount the 16mb card.

    What I'm trying to say is the reader won't mount the 64mb card. I could
    mount it with no problems under 2.4 with this reader.
    The other strange thing is that prior to me patching inode.c both the
    camera and reader gave the same 'wrong fs...' errors with the 64mb card.
    Yet as I've said I put the original inode.c back and recompiled. yet the
    reader with the 64mb card will only give 'no media found'.

    with the 64mb card mounted in the camera fdisk -l /dev/sda give me this;

    /dev/sda1 * 1 500 63972+ 1 FAT12

    Any advice would be appreciated.

    __
    Patrick

    -
    To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
    the body of a message to majordomo@vger.kernel.org
    More majordomo info at http://vger.kernel.org/majordomo-info.html
    Please read the FAQ at http://www.tux.org/lkml/

    \
     
     \ /
      Last update: 2005-03-22 13:58    [W:0.025 / U:0.156 seconds]
    ©2003-2016 Jasper Spaans. hosted at Digital OceanAdvertise on this site