[lkml]   [2003]   [Oct]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: RH7.3 can't compile 2.6.0-test8
Marco Roeland wrote:
> On Monday October 20th 2003 at 16:01 Christian Kujau wrote:
> > Norman Diamond schrieb:
> > [...]
> > > [ndiamond@c1pc40 linux-2.6.0-test8]$ gcc -v
> > > Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/2.96/specs
> > > gcc version 2.96 20000731 (Red Hat Linux 7.3 2.96-110)
> > > [ndiamond@c1pc40 linux-2.6.0-test8]$ rpm -qa binutils
> > > binutils-
> >
> > did you try with a gcc 3.x too? perhaps it's (only) a compiler issue...
> No, you just need to upgrade binutils to version 2.12 or higher, as
> mentioned in Documentation/Changes. The gcc version is fine.

I disagree with both of you.

I downloaded binutils, I think or thereabouts (I'm away from the
machine now). It rejected rpm -U because it depends on a version of
glibc-devel which is newer than RH 7.3's version of glibc-devel. I didn't
examine yet whether it is possible to upgrade glibc-devel without upgrading
gcc, and didn't download any version of those yet in order to try binutils

The Readme for 2.6.0-test6 still said that gcc 2.95 is required (I confess
to not reading Readme for test8 yet.) I reported a compilation problem in
test6 using gcc 3.2.something in SuSE on a different machine, and it seems
believable that gcc 2.95 is still required. As mentioned at the beginning
of this thread, I understand that Red Hat's gcc 2.96 is nonstandard. If I
make any changes to binutils and glibc-devel and gcc, surely it should be to
install gcc 2.95 and related packages which would be compatible with that
version. It should not be to install gcc 3.anything, or glibc-devel or
binutils that depend on it.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2005-03-22 13:58    [from the cache]
©2003-2011 Jasper Spaans