lkml.org 
[lkml]   [2003]   [Oct]   [13]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: PPC & 2.6.0-test3: wrong mem size & hang on ifconfig
On Fri, Oct 10, 2003 at 12:20:56PM +0300, Meelis Roos wrote:

> > > 1. Network interface is detected correctly but first ifconfig command
> > > (even if it fails because of wrong arguments) hangs the machine. This is
> > > with both tulip driver (new io+mmio or mmio or just plain pio, 3 modes
> > > tried) and de4x5 driver (the card is a onboard 21140).
> > >
> > > 2. 2.4 detects full 64M of RAM, 2.6 detects only 32M of RAM.
> >
> > Interesting. Can you try the linuxppc_2_4_devel
> > (http://penguinppc.org/dev/kernel.shtml) tree and let me know if that
> > finds 32mb or 64mb of RAM?
>
> Yesterday I got the machine back from production use and tried to
> compile it. It did not compile for my configuration. I also tried
> 2.6.0-test6 that I had cheked out, it made no difference, still only 32M
> RAM and hang on ifconfig eth0 up.

-test6 BTW, should be the same. The issue is that older 2.4 doesn't
'detect' 64MB of RAM, it reads that value from data the firmware passes
on (that can be incorrect or non-existant) and what 2.6 does and (newer
2.4 does / will do) is to ask the memory controller how much memory it
thinks that it has (which in someways is more important).

What I'm trying to do is to see if the problem is something in 2.4 or
2.6, as 2.6 correctly detects 128MB on my PReP box.

--
Tom Rini
http://gate.crashing.org/~trini/
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:49    [W:0.065 / U:0.176 seconds]
©2003-2018 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site