lkml.org 
[lkml]   [2003]   [Jan]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subject2.4.18-14 kernel stuck during ext3 umount with ping still responding
Date
Hi,

I'm running a 2.4.18-14 kernel with a heavy IO profile using ext3 over RAID
0+1 volumes.

From time to time I get a black screen stuck machine while trying to umount
a volume during an IO workload (as part of a failback solution - but after
killing all IO processes ), with ping still responding, but everything else
mostly dead.

I tried using the forcedumount patch to solve this problem - to no avail.
Also tried upgrading the qlogic drivers to the latest drivers from Qlogic.

After one of the occurences I managed to get some output using the sysrq
keys.

This seems similar to what is described in
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=77508 but with a
different call trace

What I have here is what I managed to copy down (for some reason pgup/pgdown
didn't work so not all information is full...) together with a manual lookup
of the call trace
from /proc/ksyms :

process umount
EIP c01190b8 (set_running_and_schedule)
call trace:
c01144c9 f25f9ec0 IO_APIC_get_PCI_irq_vector
c010a8b0 f25f9ed0 enable_irq
c014200c f25f9ef0 fsync_buffers_list
c0155595 f25f9efc clear_inode
c015553d f25f9f2c invalidate_inodes
c01461d8 f25f9f78 get_super
c014a629 f25f9f94 path_release
c0157c58 f25f9fc0 sys_umount
c0108cab sys_sigaltstack

Any idea what can cause this ?

I'm hoping the ext3fix.patch will solve this problem... am trying that now.


Thanks,
Yuval

P.S. please CC me for questions/replies as I'm not currently subscribed to
the list.

--
Yuval Yeret
Exanet
http://www.exanet.com
Tel. 972-9-9717782
Fax. 972-9-9717778








_________________________________________________________________
Protect your PC - get McAfee.com VirusScan Online
http://clinic.mcafee.com/clinic/ibuy/campaign.asp?cid=3963

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:32    [W:0.174 / U:3.788 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site