lkml.org 
[lkml]   [2003]   [Jan]   [9]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subject2.4.19 -- ac97_codec failure ALi 5451

Sound fails on 2.4.19 with ALi 5451 built-in audio:

Trident 4DWave/SiS 7018/ALi 5451,Tvia CyberPro 5050 PCI Audio,
version 0.14.9d, 00:57:19 Jan 9 2003
PCI: Enabling device 00:06.0 (0000 -> 0003)
PCI: Assigned IRQ 10 for device 00:06.0
trident: ALi Audio Accelerator found at IO 0x1000, IRQ 10
ac97_codec: AC97 Audio codec, id: 0x4144:0x5372 (Unknown)
ali: AC97 CODEC read timed out.
last message repeated 127 times
ali: AC97 CODEC write timed out.
ac97_codec: AC97 codec, id: 0x0000:0x0000 (Unknown)

The trident driver was compiled in during this run. lspci --

00:06.0 Multimedia audio controller: Acer Laboratories Inc. [ALi] M5451
PCI AC-Link Controller Audio Device (rev 02)

I've also tried Alsa, and the snd-ali5451 module loads under lengthy
protests from

alsa-kernel/pci/ali5451/ali5451.c:389 ali_codec_ready: codec not ready

The related modules also load and everything looks fine.

No sound in either case, trident or snd-ali5451.

This is a matrix vpr 200A5 laptop running Debian's kernel 2.4.19-5.

I've seen other people have had similar problems; is this a problem with
recent AC-97 codec revisions?

Cheers,
Peter


-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:32    [W:0.100 / U:0.536 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site