[lkml]   [2003]   [Jan]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [RFC] irq handling code consolidation, second try (v850 part)
On Sat, Jan 04, 2003 at 04:03:52PM +0300, Andrey Panin wrote:
> I used arch_ prefix to clearly mark arch specifig things, but
> irq_valid() is probably a better name. Comments ?

You should only `mark arch specific things' when there's a reason --
after all, there are _lots_ of arch-specific definitions in linux, but very
rarely is it important to note that fact; the caller usually doesn't care.

[consider that it might be desirable at some point in the future to have a
arch-independent version of `irq_valid'; the callers shouldn't have to be
changed to accomodate such a change]

In the case of something like `arch_setup_irq', there _is_ a reason: it's a
small arch-specific `core' for the real generic setup_irq (and one which will
probably be used _only_ by setup_irq).

Ich bin ein Virus. Mach' mit und kopiere mich in Deine .signature.
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2005-03-22 13:32    [W:0.040 / U:0.160 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site