[lkml]   [2003]   [Jan]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: [RFC] irq handling code consolidation, second try (v850 part)
On Sat, Jan 04, 2003 at 10:00:29PM +0900, Miles Bader wrote:
> Can't test it, but the v850 part looks great, ah, it's lovely to see all
> that code being deleted...
> One comment: `arch_check_irq' is a bad name, it doesn't make it at all
> clear what it does.
> I might suggest inverting the sense, and using `irq_valid' -- the `arch_'
> prefix seems unnecessary (as with `irq_desc') since it's not a
> arch-specific version of a more general wrapper.

I used arch_ prefix to clearly mark arch specifig things, but
irq_valid() is probably a better name. Comments ?

Andrey Panin | Embedded systems software developer | PGP key:
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2005-03-22 13:32    [W:0.043 / U:1.776 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site