lkml.org 
[lkml]   [2003]   [Jan]   [31]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectNFS problems, 2.5.5x
Synopsis:  nfsserver:/home/david mount, get dir. entries loops forever, 
2.5.59 for client and server.

Example: ls -l /home/david

An strace will show the same directory entries flying by over and over
until memory is exhausted or ^c comes along. It worked at first for
about 30 minutes while I finished the new gentoo install on my desktop,
but then things got weird. the nfs server spat out a big long callback
trace (oops) and died hard. Had to reset the power. The looping
started just minutes before that. I've rebooted, tried 2.5.53 on the
client but no go.

Doing a stat on a single file works fine. Doing a glob, i.e. ls -l on
the mount directory fails. Doing ls -l on any sub directory of the
mount works fine.

ls -la /home/david/.xinitrc (file, works)
ls -la /home/david/.e (directory, works)
ls -la /home/david (loops forever on all directory entries until memory
is exhausted and ls aborts)

Some things I've noted:

- not all directory entries are repeated, some only appear once and
never again.
- ls only does this on the mount point of the nfs mounted directory, all
other directories are fine

GLIBC 2.3.1, underlying filesystems are reiserfs.

Client:
nfsserver:/home/david on /home/david type nfs
(rw,bg,hard,intr,timeo=7,rsize=16384,wsize=16384,addr=10.0.0.5)

Server (/var/lib/nfs/etab):
/raid/home/david
hb.blue-labs.org(rw,async,wdelay,hide,secure,no_root_squash,no_all_squash,subtree_check,secure_locks,mapping=identity,anonuid=-2,anongid=-2)


David


-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:32    [W:0.047 / U:1.476 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site