lkml.org 
[lkml]   [2003]   [Jan]   [31]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subject2.4.21-pre4 / IrDA on a Dell C640, still no go
I've had a bit more time to try the smsc-ircc2 driver, but as
its predecessor it fails to find an irq for the chip
(LPC47N252), printing out

IrCC version 2.0, firport 0x290, sirport 0x3e8, dma=3, irq=0

I tried booting into Win2K, where the driver claims to be using
irq 3, rebooted in 2.4.21-pre4, said

[root@incident root]# insmod smsc-ircc2 ircc_irq=3

but apart from getting a printk saying

smsc-ircc2, Overriding IRQ - chip says 0, using 3

I still see nothing doing irdadump, and /proc/interrupts only
shows these:

0: 324401 XT-PIC timer
1: 3592 XT-PIC keyboard
2: 0 XT-PIC cascade
9: 5 XT-PIC acpi
11: 0 XT-PIC Intel ICH3, Texas Instruments PCI1420,
Texas Instruments PCI1420 (#2), usb-uhci
12: 6 XT-PIC PS/2 Mouse
14: 3987 XT-PIC ide0
15: 0 XT-PIC ide1

There is no option in the Dell BIOS to choose an IRQ for the
IR chip (as it isn't there in this CPx750J, but this one works
just fine on irq 4).


Any suggestion on how to go on from here is welcome !


Thanks, ciao,

--alessandro
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:32    [W:0.057 / U:0.556 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site