lkml.org 
[lkml]   [2003]   [Jan]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Date
SubjectOne-way Gigabit Ethernet TCP performance with Jumbo frames


Steffen Persvold writes:
> Hi all,
>
> Lately I've been testing out two Gigabit Ethernet adapters on Pentium 4
> Xeon platforms; onboard Intel 82544GC (e1000 driver) and onboard Broadcom
> BCM5701 (tg3 driver), and I'm experiencing some wierd behaviour on
> one-way tests (ping-ping). The machines I'm testing is connected back to
> back (i.e no switch) and are fairly fast systems (Dual Xeon 2.4 GHz, 1GB
> memory) configured to use Jumbo frames (9000 bytes).


> But, when running a one-way test (where one machine only sends, and the
> other only receives, i.e ping-ping) there is a serious dip in the
> performance curve at ~768 bytes and the bandwidth levels out at approx
> 60 MByte/sec (about half of peak) regadless of application and GbE device.

I've seen similar problems... and most of the times this seems due to
incorrect tuned mitigation. Think of what happens if you don't have TX-
interrupts enough to clean your TX-ring. Which means your app. can not
fill it at full speed -- and as long you have RX traffic it contributes
with interrupts so the problem is not visile.

If you test IP-forwarding with RX soly on one interface and TX soly on the
other and routing between them. You'll see drops at the qdisc in such case.

Cheers.
--ro




-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:32    [W:0.037 / U:3.792 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site