lkml.org 
[lkml]   [2003]   [Jan]   [27]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectPromise PDC20276 broken in 2.5 and 2.4.21-preX, but not 2.4.20
There have been two prior reports of a problem with the promise PDC20276 
chipset (on-board piece-o-crap pseudo raid on some KT333 [and others?]
motherboards). Both of them reported the same problem, i.e. load the
pdc202xx_new driver and get "neither IDE port enabled (BIOS)" message,
and therefore an inability to use drives on that controller using either
the direct ide interface or the pdcraid module. This problem was
reported on both kernels 2.4.21-pre1 and 2.5.46, and was reported to
work correctly with 2.4.20 and 2.5.34.

Neither person got a response (at least on the list), so I can't tell if
anybody is aware of this.

I'm guessing that the 2.5 problem was introduced here
http://linux.bkbits.net:8080/linux-2.5/diffs/drivers/ide/pci/pdc202xx_new.c@1.4

and the corresponding 2.4 backport
http://linux.bkbits.net:8080/linux-2.4/cset@1.757.33.36?nav=index.html|tags|ChangeSet@..1.811

I've run into the same problem with 2.4.21-pre3-ac4, and can also verify
that it works fine with 2.4.20.

Any takers on why the 20276 isn't getting initialized correctly
anymore? Presumably this is not a problem with most of the other promise
chipsets or it would be much more heavily noticed by now.

-Tupshin



-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:32    [W:0.026 / U:1.348 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site