lkml.org 
[lkml]   [2003]   [Jan]   [25]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subject[Problem] 2.4.18 & 20 spontaneously resetting w/CompactFlash
Hi,

I have a VIA EPIA mini-ITX system booting from a CompactFlash card via
an IDE adapter. The OS installs to the CF card just fine via a boot
floppy and a kickstart using an NFS server. But once the machine boots
from the CF card, it will either reset part way into the kernel load,
during init, or shortly after going to a login prompt. There are no
error or warning messages, just a sudden reset.

After duplicating this behavior on a second machine, I installed the
same minimal OS on a hard drive, with no issues. I then tried another
brand/speed of CF card, and voila, no more problems. The original cards
(I tried two) were brand-new SimpleTech, 3MB/s cards. The one that
works is an older Lexar, whatever "4x" means, but I know it is slower.

So, my question is, does this sound like a hardware issue, or a
kernel issue? I'd be inclined to say it was hardware. I have googled
extensively but found no others mentioning this problem. However,
the install goes fine, and this resetting happens only after the
kernel begins to boot, no instability before that. Though of course
before that the only thing that happens is grub loads. Any ideas?

Larry
--
Lawrence Weeks "Audaces fortuna juvat." dev@anabasis.net
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:32    [W:0.043 / U:2.276 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site