lkml.org 
[lkml]   [2003]   [Jan]   [22]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectAH transformation broken since 2.5.56
Hi,

Support for IPsec AH in net/ipv4/ah.c is broken since 2.5.56
(still broken in 2.5.59).
I tried with CONFIG_INET_AH=y and m, I got the same error :

make -f scripts/Makefile.build obj=net/ipv4
gcc -Wp,-MD,net/ipv4/.ah.o.d -D__KERNEL__ -Iinclude -Wall -Wstrict-prototypes
-Wno-trigraphs -O2 -fno-strict-aliasing -fno-common -pipe
-mpreferred-stack-boundary=2 -march=i686 -Iinclude/asm-i386/mach-default
-fomit-frame-pointer -nostdinc -iwithprefix include -DMODULE
-DKBUILD_BASENAME=ah -DKBUILD_MODNAME=ah -c -o net/ipv4/ah.o net/ipv4/ah.c
net/ipv4/ah.c: In function `ah_hmac_digest':
net/ipv4/ah.c:154: warning: implicit declaration of function `crypto_hmac_init'
net/ipv4/ah.c:155: `crypto_hmac_update' undeclared (first use in this function)
net/ipv4/ah.c:155: (Each undeclared identifier is reported only once
net/ipv4/ah.c:155: for each function it appears in.)
net/ipv4/ah.c:156: warning: implicit declaration of function `crypto_hmac_final'
make[2]: *** [net/ipv4/ah.o] Erreur 1
make[1]: *** [net/ipv4] Erreur 2
make: *** [net] Erreur 2

Regards

Brice Goglin
============
Ph.D Student
Laboratoire de l'Informatique et du Parallélisme
ENS Lyon
France
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:32    [W:2.987 / U:5.356 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site