[lkml]   [2003]   [Jan]   [21]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectRe: Spurious 8259A interrupt: IRQ7 ????
David D. Hagood wrote:

> AnonimoVeneziano wrote:
>> What does it mean this message?
>> Of what problem is the signal?
> It is most likely a hardware problem.
> When a device signals an interrupt, it asserts its interrupt pin. When
> the CPU asks the interrupt controller what device generated the
> interrupt, the interrupt controller tells the CPU.
> But if the interrupt line "goes away" before the CPU fetches the
> vector, then the interrupt controller doesn't "know" what IRQ caused
> the interrupt. So the interrupt controller sends an IRQ #7 to the CPU,
> along with setting a bit in the interrupt controller's status register
> that says in effect "this isn't really an IRQ 7, but I have no idea
> what it was. Sorry."
> If you have ISA cards in your system, remove them from the system and
> re-insert them (with the power off, of course) - they may have
> developed some oxidization on the card edge connector. You can also
> try scrubbing the card edge with some plain paper (a US dollar bill
> works even better, but you might not have access to dead presidents in
> Italy.)
> Ditto with PCI cards - remove them, polish the connector, then
> re-insert them.
Thank you very much all of you for the answers.So, this should be an
harmless message, I've tried to attach something to the parallel port ,
or disable it in the bios, but doesn't work, the only way to remove this
problem is to load the parport_pc module, this message with the module
loaded doesn't appear. I've tried with other bioses , and the problem
appears on all of them. If I compile in the kernel UP-IO-ACPI the
problem disappears, but I have a lot of other problems, because my
system is quite young and the support for IO-APIC is not added yet for
me.If I use only UP-APIC this problem appears, and if don't use apic
this disappears.

I'll try to remove some HW and retry. Someone had this problem without
APIC enabled?

Thank you



To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2005-03-22 13:32    [W:0.090 / U:6.100 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site