lkml.org 
[lkml]   [2003]   [Jan]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subjectcardbus modem not handled by the serial driver
   Hi there,

My Xircom RBM56G cardbus modem works fine with the
serial_cb driver in 2.2 kernels, but is not handled
correctly by the serial driver in 2.4 kernels. I've
been trying to add support for that modem to serial.c,
but I don't understand the driver well enough in order
to make it work. If there is anyone who can help me
with suggestions, I'd be happy to do the testing.

Here's what I've tried: as the modem/ethernet combo
apparently is handled correctly by the serial driver,
I tried adding

{ PCI_VENDOR_ID_XIRCOM, 0x0101,
PCI_ANY_ID, PCI_ANY_ID, 0, 0,
pbn_xircom_combo },

to __devinitdata. The result in the system logs is
this:

kernel: cs: cb_alloc(bus 2): vendor 0x115d, device 0x0101
kernel: PCI: Enabling device 02:00.0 (0000 -> 0003)
kernel: ttyS4 at port 0x4000 (irq = 10) is a 16550A
cardmgr[527]: initializing socket 0
cardmgr[527]: socket 0: Serial or Modem
cardmgr[527]: executing: 'modprobe serial_cs'
kernel: serial_cs: ParseTuple: No more items
cardmgr[527]: executing: './serial start serial'
/etc/hotplug/pci.agent: ... no modules for PCI slot 02:00.0
cardmgr[527]: + don't know how to make device "serial"
cardmgr[527]: + /dev/serial: No such file or directory
last message repeated 2 times
cardmgr[527]: exiting

I'd be happy to hear any better suggestions.
Thanks,
Dirk

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:32    [W:0.038 / U:2.548 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site