lkml.org 
[lkml]   [2003]   [Jan]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: Linux 2.4.21-pre3-ac3 and KT400 -high memory now works!
From
Date
On Tue, 2003-01-14 at 21:49, Edward Tandi wrote:
> On Tue, 2003-01-14 at 01:43, Samuel Flory wrote:
> > Edward Tandi wrote:
> >
> > >I'm new to this list and most of the e-mail here seems to be very
> > >low-level, so I'm not so sure if this is the right forum for these kinds
> > >of questions -please do point me in the right direction...
> > >
> > >I am running Linux on an ASUS A7V8X, VIA KT400 chipset motherboard. The
> > >processor is a 1.5GHz Athlon XP. I started experimenting with new-ish
> > >kernels again because of the general lack of kernel support for this
> > >chipset in stock kernels. 3 questions below:
> > >
> > >
> > >1) I have 1GB ram, but I cannot get high memory support to work. It
> > >falls over during boot. I've seen discussions about AMD cache issues,
> > >but has it been fixed yet? Is it supposed to work?
> > >
> > Have you tried to forcing the amount of memory? Try something short
> > of you expected total. Maybe "mem=1000M".
>
> OK, I tried this. If I set it to 800M it was OK. At 900M I got the same
> problem.
>
> Due to the nature of the replies I have been getting, I suspected that
> the problem was with the IDE driver's initialisation. So I disabled the
> "Use PCI DMA by default" option in the kernel.
>
> It booted with the full amount of high memory. Not only that, but
> "hdparm -X66 /dev/hda" after booting also works!
>
> I can only conclude that there must be a bug in the IDE initialisation
> code for this board. Thanks for the replies.

Oops, I forgot to enable DMA transfers with "hdparm -d 1". It turns out
that (U)DMA transfers don't work when high memory is enabled. The
problem _is_ the IDE driver.

Ed-T.

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:32    [W:0.049 / U:13.296 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site