lkml.org 
[lkml]   [2003]   [Jan]   [14]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: 2.4.19 - 2.4.20 : Boot parameter MEM= doesn't work anymore
On Tue, Jan 14, 2003 at 03:38:54PM +0100, Dick Streefland wrote:
> For some reason, the interpretation of the mem= kernel parameter was
> changed. I ran into this myself. The value is now used to limit the
> memory size, not overrule it. There is a different syntax for adding
> memory. One of my computers has 128 Mb, of which only 64 Mb are
> detected. I had to add the "mem=63m@65m" kernel parameter, resulting in:
>
> [...]
>
> Unfortunately, this is not documented. Look at arch/i386/kernel/setup.c
> for details.
>
Thank you for your answer Dick. I tried to add the "mem=47m@17m" kernel
parameter (only 16M are found so 48 need to be forced) even if the
reason why wee need to start from "the next meg" and to add only X-1M is
not realy clear for me. Now it actualy force 64MB so it's ok.
Thank you again.

------ kern.log
klogd 1.4.1#10, log source = /proc/kmsg started.
Inspecting /boot/System.map-2.4.20
Loaded 17390 symbols from /boot/System.map-2.4.20.
Symbols match kernel version 2.4.20.
Loaded 23 symbols from 4 modules.
Linux version 2.4.20 (root@orion) (gcc version 2.95.4 20011002 (Debian
prerelease)) #1 Tue Jan 14 19:21:24 CET 2003
BIOS-provided physical RAM map:
BIOS-88: 0000000000000000 - 000000000009f000 (usable)
BIOS-88: 0000000000100000 - 0000000001000000 (usable)
64MB LOWMEM available.
On node 0 totalpages: 16384
zone(0): 4096 pages.
zone(1): 12288 pages.
zone(2): 0 pages.
Kernel command line: auto BOOT_IMAGE=Linux ro root=802 mem=47m@17m
------

--
Guillaume Allard
EFREI - promo 2002
allard@efrei.fr
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:32    [W:0.031 / U:5.796 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site