lkml.org 
[lkml]   [2003]   [Jan]   [12]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: Linux 2.4.21pre3-ac2
On Fri, 10 Jan 2003, Jean-Daniel Pauget wrote:

>
> I had some strange bug using 2.4.21pre3-ac2 :
> at rebooting after a freeze (my machine freezes from time to time
> whatever the kernel is, I'm still diging that point)
> fsck.ext2 was not able to finish checking my /home (59Gb), it
> systematically got a signal 11 (I tried several times).
>
> rebooting using my previous kernel (2.4.20 with a minor patch for the
> i845G AGP mess-up) was enough so that the fsck worked fine at the first
> attempt with this kernel.

There are several possibilities, but I would suspect you have memory which
is just marginal, and with some combination of access patterns you trigger
a sig 11 problem. I have the same board, with 72 bit ECC capable memory,
and I'm running all of the BIOS speed options (section 4.4 of the manual)
set at default, rather than tuning for any extra bit of performance.

If you have pushed any of the CPU or memory speeds, obviously that's a
place to return to default, but I suspect what you have is marginal
memory. Best is to borrow a stick and run on other memory, 2nd best is to
slow the speeds a bit and see if that works better.

Clearly this is only an educated guess.

--
bill davidsen <davidsen@tmr.com>
CTO, TMR Associates, Inc
Doing interesting things with little computers since 1979.

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:32    [W:0.134 / U:1.844 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site