lkml.org 
[lkml]   [2003]   [Jan]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: [2.5 patch] go to drivers/ide/pci/ even for !CONFIG_BLK_DEV_IDEPCI
Date
> I observed the following problem with the cmd640 driver in 2.5.56:

I know

> - cmd640.c is in the drivers/ide/pci/ subdirectory.
> - BLK_DEV_CMD640 does not depend on BLK_DEV_IDEPCI

This is correct

> - drivers/ide/Makefile only goes to pci/ if BLK_DEV_IDEPCI is selected
> If the .config contains the following legal configuration:

There are a lot of configurations with this property.

> The following patch fixes this (similar to 2.4 where pci/ is already
> visited for !CONFIG_BLK_DEV_IDEPCI):
>
> --- linux-2.5.56/drivers/ide/Makefile.old 2003-01-11 13:52:30.000000000 +0100
> +++ linux-2.5.56/drivers/ide/Makefile 2003-01-11 13:52:51.000000000 +0100
> @@ -10,7 +10,7 @@
> export-objs := ide-iops.o ide-taskfile.o ide-proc.o ide.o ide-probe.o ide-dma.o ide-lib.o setup-pci.o ide-io.o
>
> # First come modules that register themselves with the core
> -obj-$(CONFIG_BLK_DEV_IDEPCI) += pci/
> +obj-$(CONFIG_BLK_DEV_IDE) += pci/

I think thats the best approach.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:32    [W:0.046 / U:24.388 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site