lkml.org 
[lkml]   [2003]   [Jan]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subjectgetting my serial ports back? ;-)
What do I have to do to get my serial ports back?

devfs: v1.22 (20021013) Richard Gooch (rgooch@atnf.csiro.au)
devfs: boot_options: 0x1
pnp: the driver 'serial' has been registered
pnp: pnp: match found with the PnP device '00:0f' and the driver 'serial'
pnp: the device '00:0f' has been activated
devfs_register(tts/2): could not append to parent, err: -17
tts/2 at I/O 0x3e8 (irq = 4) is a 16550A
pnp: pnp: match found with the PnP device '00:10' and the driver 'serial'
pnp: the device '00:10' has been activated
devfs_register(tts/3): could not append to parent, err: -17
tts/3 at I/O 0x2e8 (irq = 3) is a 16550A

Effectively as my mouse is on the serial port and it
obviously does not work in gpm or with X directly.

ttyS0: LSR safety check engaged!
ttyS0: LSR safety check engaged!
ttyS0: LSR safety check engaged!
ttyS1: LSR safety check engaged!
ttyS1: LSR safety check engaged!
ttyS1: LSR safety check engaged!

That's coming from gpm startup, at least one of it, although
I have /dev/tts/0 in my gpm.conf... Ah, it's hardcoded in the
binary, it seems (doing a strings on it).

Anyway, does anyone have a clue as to why my serial modules
are not working any longer since 2.5.53 (and neither 2.5.55)?
I am not missing it much for X but at least gpm is a good
thing.

Thanks,
Alexander

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:32    [W:0.026 / U:0.120 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site