lkml.org 
[lkml]   [2003]   [Jan]   [11]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
Subject2.5.56 strange behaviour
Hi, i've observed an "strange" thing in 2.5.56 (and 2.5.55 too)

procs -----------memory---------- ---swap-- -----io---- --system-- ----cpu----
r b swpd free inact active si so bi bo in cs us sy id wa
0 0 0 6228 92524 134716 0 0 0 0 1698 2257 1 0 98 0
<two "dd if=/dev/zero of=test bs=4M" here>
3 0 0 26384 79468 131012 0 0 12 8192 1784 2163 1 33 60 5
1 1 0 4404 115528 119768 0 0 4 43616 2013 3825 2 63 14 22
0 4 0 2076 118480 118896 0 0 8 40456 2027 2251 1 44 6 49
0 3 0 4100 116444 118792 0 0 0 41184 2044 2614 2 5 0 94
3 2 0 4028 116368 119120 0 0 0 37768 2041 2196 1 53 6 40
3 2 0 12040 117608 109764 0 0 8 41456 2048 2403 1 55 10 33
1 3 0 3852 127036 108344 0 0 4 36140 2012 2473 1 53 6 40
0 5 284 2168 130556 106468 0 284 0 47564 2061 2665 2 44 2 51
0 3 1884 4064 129808 105288 0 1504 0 42028 2062 2360 1 44 12 44
<one "dd if=/dev/zero of=test bs=4M" here>
1 4 2424 2228 132204 104732 0 540 16 39768 2091 2508 1 41 2 57
1 3 3232 4072 130772 104332 0 904 12 43156 2050 2569 1 43 6 49
1 2 4524 4584 130892 103656 0 1292 4 37680 2031 2608 2 43 6 49
1 3 4524 5136 130340 103724 0 0 0 47024 2060 2491 1 49 4 46
4 4 4524 2240 132948 103972 0 0 0 40588 2063 5791 1 48 8 44
<two "dd if=/dev/zero of=test bs=4M" here>
4 4 5188 4052 130768 104264 0 664 4 41896 2063 199652 1 80 0 18
3 1 5188 4232 131112 103752 0 0 44 40172 2156 237791 3 94 0 3
4 3 5188 3572 132208 103320 0 0 16 44332 2068 252186 1 95 1 4
2 1 5188 4292 131488 103256 0 0 0 40852 2056 302306 1 81 7 10
0 3 5188 4192 131528 103248 0 0 340 29672 1974 182712 1 69 14 17
^^^^^^

1 0 5188 90728 47484 103436 28 0 68 21224 1931 2178 2 64 25 8
1 2 5188 32432 104000 103492 0 0 0 44924 2047 2200 2 57 9 33
0 3 5188 7068 128576 103512 0 0 0 35064 2028 2200 1 27 15 58
1 3 6108 3800 131884 103176 0 920 0 40184 2041 2135 1 32 11 56
1 3 6108 2188 133672 103028 0 0 0 42048 2037 2351 2 32 5 61
diego@estel:~$

As you see, the cs rate goes from 2??? to 200000-300000.
I wanted to know if it's the expected behaviour.

The test file is the same in all the dd's.


If you need info:

The machine is a P3 2x800 with 256 ram; UDMA 100 ide disk;
FS is ext3 (no htree or the orlov thing).
everything is in the same disk. While it does that;
it's doing nothing except X+gnome (in the background)
playing ogg (which increases the cs)
I reproduced it without X/ogg playing.

I've managed to save slabinfo attached (if it helps...)

I observed it in 2.5.55 for the first time; it was not easy
to reproduce but it happened. Strangely it happened
the first time this afternoon after a mail/web/irc idling session.


[unhandled content-type:application/octet-stream]
\
 
 \ /
  Last update: 2005-03-22 13:32    [W:0.034 / U:3.292 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site