lkml.org 
[lkml]   [2003]   [Jan]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: BLKBSZSET still not working on 2.4.18 ?
Date
> > I'm trying to backup a partition on an IDE drive which has an odd number 
> > of sectors (204939). With a stock open/read you cannot access the last
> > sector, and that why I tried the BLKBSZSET ioctl to set the basic read
> > block size to 512 bytes. I verified the writen value with BLKBSZGET
> > ioctl, but I still cannot read this last sector !
>
> Its a known 2.4 limitation. The last odd sector isnt normally used by
> anything so it has never been a big issue (except with EFI partition
> data).

Didn't some really obscure IBM drives use it for something internally,
and shortly after everybody else had to stop using it incase they
overwrote the custom data at the end of an IBM disk, or am I thinking
of something else?

John.
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:32    [W:0.074 / U:1.508 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site