lkml.org 
[lkml]   [2003]   [Jan]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRe: BLKBSZSET still not working on 2.4.18 ?
From
Date
On Fri, 2003-01-10 at 15:32, Ludovic Drolez wrote:
> I'm trying to backup a partition on an IDE drive which has an odd number
> of sectors (204939). With a stock open/read you cannot access the last
> sector, and that why I tried the BLKBSZSET ioctl to set the basic read
> block size to 512 bytes. I verified the writen value with BLKBSZGET
> ioctl, but I still cannot read this last sector !

Its a known 2.4 limitation. The last odd sector isnt normally used by
anything so it has never been a big issue (except with EFI partition
data). There is a patch to allow the last sector to be recovered but
its quite ugly so never went mainstream.


-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:32    [W:0.073 / U:0.236 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site