[lkml]   [2003]   [Jan]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
Messages in this thread
SubjectBLKBSZSET still not working on 2.4.18 ?
Hi !

I'm trying to backup a partition on an IDE drive which has an odd number
of sectors (204939). With a stock open/read you cannot access the last
sector, and that why I tried the BLKBSZSET ioctl to set the basic read
block size to 512 bytes. I verified the writen value with BLKBSZGET
ioctl, but I still cannot read this last sector !

I've tried also this:
- FreeBSD : works but it don't want to port all my software to it
- raw devices: can't read the last sector:

# raw /dev/raw1 /dev/hda2
# dd if=/dev/raw1 of=C bs=512
dd: reading `/dev/raw1': No such device or address
204938+0 records in
204938+0 records out

What can it do ? Wait for a patch in ?


Ludovic Drolez.

To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to
More majordomo info at
Please read the FAQ at

 \ /
  Last update: 2005-03-22 13:32    [W:0.059 / U:0.436 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site