lkml.org 
[lkml]   [2002]   [Sep]   [4]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
Subjecthang at "bringing up interface lo:"
Date
Hi,

I am runing RH linux-2.4.7-10 on a Dell Optiplex GX110 box (with 256Mb RAM).
The system worked fine with networking support. I then added a virtual
network driver (similar to
ftp://ftp.linux.it/pub/People/Rubini/insane.tar.gz) to the kernel. (There is
no change made to drivers/net/loopback.c). I compile the kernel in usual
steps (make dep, make clean, make bzImage, make modules, make
modules_install). The compilation works fine. However, when I am booting the
new kernel image, the system hangs at the prompt "bringing up interface
lo:". It does not echo "[OK]".
The system boots fine in single user mode. When I ran
"/etc/rc.d/init.d/network start", it got stuck at "./ifup ifcfg-lo".
Infact, in the ifup script, it is halting at "ip addr add
${IPADDR}/${PREFIX} brd
${BROADCAST:-+} dev ${REALDEVICE} .." called to add adrress for lo. I
checked that it is correctly using IPADDR=127.0.0.1.

Since the system works fine with old kernel image, I guess the problem is
with the new kernel image. I shall appreciate any pointer on what may go
wrong.

TIA.

Regards
Sakib



_________________________________________________________________
Chat with friends online, try MSN Messenger: http://messenger.msn.com

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:28    [W:0.051 / U:0.828 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site