lkml.org 
[lkml]   [2002]   [Sep]   [3]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
From
SubjectRe: 2.4.18 --> 2.4.19. Ramdisk requires floppy?
Date
Followup to:  <20020903165133.GA8726@southpole.se>
By author: jakob@southpole.se (Jakob Sandgren)
In newsgroup: linux.dev.kernel
>
> Hi,
>
> I've noticed that the 2.4.19 version of "prepare_namespace"
> (init/do_mounts.c) not allows you to mount a non floppy as a
> ramdisk(?). This has changed since 2.4.18 (split of main.c ->
> {do_mounts,main}.c).
>
> 2.4.18 does a very simple check (below):
>
> --- 2.4.18 ---
> #ifdef CONFIG_BLK_DEV_RAM
> #ifdef CONFIG_BLK_DEV_INITRD
> if (mount_initrd)
> initrd_load();
> else
> #endif
> rd_load();
> #endif
> --- 2.4.18 ---
>
> however, in 2.4.19 it just tries to load a ramdisk if it's on a
> floppy. Why? There may still be a ramdisk on an other device, NOT
> using initrd.
>

You can't search every device hunting for a ramdisk. rd_load() is
ancient cruft that should be nuked, and will be pushed into userspace
as part of the initramfs/early userspace work.

-hpa
--
<hpa@transmeta.com> at work, <hpa@zytor.com> in private!
"Unix gives you enough rope to shoot yourself in the foot."
http://www.zytor.com/~hpa/puzzle.txt <amsp@zytor.com>
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:28    [W:0.036 / U:1.016 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site