lkml.org 
[lkml]   [2002]   [Sep]   [10]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
SubjectRE: [RFC] Multi-path IO in 2.5/2.6 ?
Date
From

Alan Cox wrote:

> On Tue, 2002-09-10 at 15:43, Cameron, Steve wrote:
> > Well, the BIOS can do it if it has one working path, right?
> > (I think the md information is at the end of the partition,)
>
> Yes. A good PC bios will spot an hda boot fail, and try hdc. Good PC
> bioses are alas slightly hard to find nowdays. In that set up raid1
> works very well. Multipath is obviously a lot more complicated.

For the failed primary path case yes. In the case the primary path is
working, I would think booting from a multipath device and a RAID1
device would be very very similar, or even identical, from the
perspective of the BIOS, right?

> > lilo and grub as they stand today, and anaconda (et al) as it
> > stands today, cannot do it. They can do RAID1 md devices only.
> > lilo for example will complain if you try to run it with
> > boot=/dev/md0, and /dev/md0 is not a RAID1 device. At least
>
> It relies on the BIOS to do the data loading off the md0. In your
> scenario you would tell it the boot is on /dev/sdfoo where that is the
> primary path. I guess the ugly approach would be to add lilo/grub
> entries for booting off either path as two seperate kernel entries.
>

Hmm, I thought I had tried this, but, I had tried so many things.
If anyone has successfully set up a system booting from a multipath
md device, I'd like to hear about it.

What I tried was more or less this:

1. Install normally to disk-A, remove disk-A from the system.
2. Install normally to disk-B. Install disk-A into the system.
and boot from disk-B. (now I can safely copy from disk-A, which has
no actively mounted partitions.)
3. Create multipath devices on disk-C, one for each partition.
The partitions are bigger than those on disk-A, to allow for md to
put its data at the end.
4. Copy, (using dd) the partitions from disk-A to the md devices.

5. mount the md devices, and chroot to the md-root device.
Try to figure out how to run lilo to make booting from disk-C possible
also, initrd modifications to insmod multipath.o, mount the md devices,
etc. This part, (making lilo work) I never was able to figure out.

Would boot up and say "LI" then stop... or various other problems
that I can't quite recall now. (this was a couple weeks ago)

I guess this is getting a little off topic for linux-kernel, so maybe I
should let this drop now, or take it over to linux-raid, but I _would_
like to hear from anyone who has got a multipath boot device working.

Anyway, even if this can be made to work, this leaves a rather ugly and
convoluted method of installation.

> > bit, but so far, I am unsuccessful. I think grub cannot even do
> > RAID1.
>
> Works for me

Ok, good to hear. (I had it only on hearsay that grub couldn't do it,
so my experiments were confined to lilo.)

-- steve


-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:28    [W:0.047 / U:26.812 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site