lkml.org 
[lkml]   [2002]   [Aug]   [7]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
/
Date
From
SubjectRe: [bug, 2.5.29, IDE] partition table corruption?

On Wed, 7 Aug 2002 Andries.Brouwer@cwi.nl wrote:

> > using 2.5.29 (vanilla or BK-curr) i cannot use /sbin/lilo anymore
> > to update the partition table.
>
> > if i do it then the partition table gets corrupted and the system
> > does not boot - it stops at 'LI'.
>
> The funny thing is, I removed some stuff here in 2.5.30,
> so I would understand things immediately if you reported this
> about 2.5.30. But for 2.5.29 I do not immediately see why
> you would see any changes.

2.5.30 breaks as well.

> Did you in the meantime find out what was wrong?

nope. I still keep working it around.

> Are things OK in 2.5.28 and wrong in vanilla 2.5.29
> with the same version of LILO? (which version?)

a fairly standard LILO from RH 7.3: linux-21.4.4-10.

> Do you use the linear or lba32 options? The fix-table option?

I use none of these options. I use a very simple setup, a proper /boot
partition, nothing complex or unexpected.

> What corruption do you see in the partition table?

nothing in the descriptors that i can tell from looking at fdisk output -
but it would be pretty hard to recover the system via a pure rescue CD
otherwise.

> Do you use LVM?

nope. Plain old IDE, ext3fs,

> What happens under 2.5.30?

the same 'LI' message.

I'll try Alan's suggestion of adding the 'linear' option.

Ingo

-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/

\
 
 \ /
  Last update: 2005-03-22 13:22    [W:0.047 / U:0.572 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site