lkml.org 
[lkml]   [2002]   [Aug]   [5]   [last100]   RSS Feed
Views: [wrap][no wrap]   [headers]  [forward] 
 
Messages in this thread
Patch in this message
/
Date
From
SubjectRe: Linux 2.4.19-ac4
> > The IDE debugging continues. -ac4 should fix the breakages in ac2/ac3. It
> > hopefully also fixes the ALi hangs with non ALi north bridges (mostly
> > Transmeta boxes).
>
> It is a nice shrubbery, but there is one small problem!!
>
> # depmod -ae -F /boot/System.map-2.4.19-ac4 2.4.19-ac4
> depmod: *** Unresolved symbols in /lib/modules/2.4.19-ac4/kernel/drivers/ide/ide-mod.o
> depmod: pci_enable_device_bars

Why not ask Roger the Shrubber?


diff -urN linux-2.4.19-ac4/drivers/ide/ide-pci.c linux-2.4.19-ac4.n/drivers/ide/ide-pci.c
--- linux-2.4.19-ac4/drivers/ide/ide-pci.c 2002-08-05 20:41:59.000000000 +0200
+++ linux-2.4.19-ac4.n/drivers/ide/ide-pci.c 2002-08-05 20:28:31.000000000 +0200
@@ -693,7 +693,7 @@
}

if (pci_enable_device(dev)) {
- if(pci_enable_device_bars(dev, 1<<4))
+ if (pci_enable_device_bars(dev, 1 << 4))
{
printk(KERN_WARNING "%s: (ide_setup_pci_device:) "
"Could not enable device.\n", d->name);
diff -urN linux-2.4.19-ac4/drivers/pci/pci.c linux-2.4.19-ac4.n/drivers/pci/pci.c
--- linux-2.4.19-ac4/drivers/pci/pci.c 2002-08-05 20:42:00.000000000 +0200
+++ linux-2.4.19-ac4.n/drivers/pci/pci.c 2002-08-05 20:28:21.000000000 +0200
@@ -2082,6 +2082,7 @@
EXPORT_SYMBOL(pci_write_config_dword);
EXPORT_SYMBOL(pci_devices);
EXPORT_SYMBOL(pci_root_buses);
+EXPORT_SYMBOL(pci_enable_device_bars);
EXPORT_SYMBOL(pci_enable_device);
EXPORT_SYMBOL(pci_disable_device);
EXPORT_SYMBOL(pci_find_capability);
-
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
\
 
 \ /
  Last update: 2005-03-22 13:22    [W:0.170 / U:1.972 seconds]
©2003-2020 Jasper Spaans|hosted at Digital Ocean and TransIP|Read the blog|Advertise on this site